WordPress 5 and SSL changes 2/18/2019

On February 18 at 5am, the WordPress software powering Publish.Illinois.Edu will be upgraded to WordPress 5.0.3. There will be a brief period of downtime while the upgrade is applied.

WordPress 5 comes with a new editing experience known as Gutenberg or Block Editor. Because some content or themes may not be fully compatible with the block editor, we will also be installing and network enabling the Classic Editor plugin. Initially all sites will be set to use the classic editor and authors will not be allowed to choose their editor. Site administrators can change the default editor for their websites from the Dashboard at Settings→Writing. If you wish, you can also allow users (including yourself) to choose which editor to use each time you edit content. For more in-depth instructions on setting up the editing experience, visit https://answers.uillinois.edu/illinois/pie-editorsettings.

We will also be making a change to our SSL handling during this upgrade: going forward all Publish websites will be served over https. SSL Certificates for custom illinois.edu domains will be created automatically and these site owners will no longer be required to submit an SSL Certificate Request. Site owners with non-illinois.edu custom domains will need to continue submitting SSL requests at this time. For more information on Publish and SSL please visit https://answers.uillinois.edu/illinois/pie-ssl.