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Creating Accessible Excel Tutorial 

General Information 
This helps a screen reader to get a brief view of the worksheet before reading it. 
 

1. Name the worksheet. Double-click on the tab name and type in a new, descriptive 
name.  

 
 *Do not use backslash or brackets; space is fine. 
   

2. Provide Help Text 

• Provide Help Text for navigation using screen readers, in cell A1. 

• Type “Press TAB to move to input area. Press UP or DOWN ARROW in column A 
to read through the document.” in cell A1.  

• Make this text fairly small and change the color to match the background color 
so that only screen reader could “see” this. 

   
3. Provide description for the worksheet 

• After the Help Text line, insert a line and writes some sentences in cell A2 to 
describe current worksheet, including how many tables and charts are there in 
this worksheet and their names.  

Example: “This worksheet contains two tables. The first one is the data of all truck 
model sold. The second one is the frequency table generated from the data.” 

   
4. Fill out Document Properties 

 For Windows: 

 
• Click the File tab, and choose Prepare for Sharing, on the right side there is a 

frame containing the properties. 
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• Insert info of properties here, or access the traditional document properties by 
clicking the work Properties and choosing Show Document Panel. 

   

 
• Fill in information and check a standard format for different course files. 

 
 For Mac: 

 
• On the File menu, click properties, choose Summary. 

 

Tables 
1. Provide description for each table. 

• Insert a line before the table and writes some sentences to describe it in column 
A, including table name, how many columns are there in this table and the 
meaning of each column.  

 
Example: “The second table is the min max and count table of raw data. It contains 3 
columns. The first column is the shortest waiting time. The second column is the 
longest waiting time. The third column is the total records of waiting time.” 
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2. Provide row and column headers (names). 

 
• Make sure to indicate headers for columns and rows.  

• If there are no headers for columns, select the first row in the table and right 
click to choose the insert. Then type the headers in. 

 
3. Set the table format 

• To ensure that a screen reader interprets your column headers as headers, it is 
important to make sure that you set these. 

A. Set table format. 
a) One way: select the range of cells that you want to call a table. Click 

Insert tab, choose Tables, and click Table. 
    

 
 

b) Another way: select any cell in your table, click Insert tab, choose Tables 
and click Table. Modified the cells region for “Where is the data for your 
table?”. See the following screenshot.  

    
c) Make sure to check “My table has headers” checkbox and confirm the 

range is correct. 

 
 

B. Click the Table tab in the top menu and provide a valid name for this table. 
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• Space is not allowed here.  

• The name should begin with a letter or an underscore.  

• If the excel file has two or more worksheets and some worksheets have the 
same tables, you can name the table as TableName_in_Worksheet_Name.  

Example: “RawData_in_Relative_Frequency” and “RawData_in_Histogram”. 
 

** If a current table CANNOT be set into a table format with any reasons as shown in 
the following alert, use “Title Region” for table headers.  

    
 

C. Title Region for Table Headers 
Define the Title Region if a table cannot be set into a table format so that a screen 
reader can repeat the headers each time before it reads the value. 

  
  For tables contain both column headers and row headers: 
 
  For Windows: 

1) Find three things about a table: 
▪ Order of the table: Is this the first (or only) table on this worksheet? 
▪ Table Range: What are the addresses of the top left and bottom right 

cells in your table? (including headers) 
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▪ Order of the worksheet: Is this worksheet the first (or only) worksheet in 
this workbook? 

2) To get started, select the top-left cell in your table, DO NOT count the 
description. 

   Count all row and column headers as part of your table. 

 
 

3) Go to the Formulas tab in the Ribbon and choose Name Manager in the 
Defined Names group. 

 
 

4) Choose New in the top left corner. A new dialog box opens. In the Name 
field, type a fairly complicated name following the template:  

 
TitleRegion+[Table order in the Worksheet]+[.]+[Range of the Table-top 
left]+[.]+[Range of the Table-bottom right]+[.]+[Worksheet Number] 

 
Example: “TitleRegion1.a2.g7.2” 
The first table on Worksheet 2 ranging from a2 (top left) to g7 (bottom right) 

 
You can ignore all the other fields in this dialog box 

 

 
 

 For Mac: 
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▪ Go to Formulas tab, click Defined Names, and choose Define Name.  
▪ TitleRegion name format stays the same as the previous one. 

 

• If your table only has column headers, define a “ColumnTitleRegion” instead of a 
“TitleRegion”.  Others are same. Follow the template:  
 

ColumnTitleRegion +[Table order in the Worksheet]+[.]+[Range of the Table-
top left]+[.]+[Range of the Table-bottom right]+[.]+[Worksheet Number] 
 
Example: “ColumnTitleRegion1.a2.g7.2” 
 

• If your table only has row headers, type “RowTitleRegion” instead of a 
“TitleRegion”. The rest of coding is the same. 

Example: “RowTitleRegion1.a2.g7.2” 

• If you create these titles first and make any change to the table, you have to 
recode the titles. Therefore, do this in the last stage of the accessibility check 
when you are ready to publish. 

• If you need to edit these names, go back to the Name Manager, select the name 
you wish to edit, and choose the Edit button. 

 
4.  If you have completed all the previous steps, the table should have column headers.  

However, if the table does not have headers and has already been determined to be 
a table, 
A. Click anywhere in the table region.  
B. Click Table tab, select the Header Row checkbox. Provide a name for this table. 
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C. Double click the cells in the header row and type in column names. 

 
 

5. Set table style. 
To make all files follow a unique style, we need to choose one style and apply it to all 
tables. Select any cell in the table, click the Table tab, click the down arrow near the 
Quick Style, and choose one style, “Table Style Medium 1”. Color needs to be black and 
white.  

    
 

6. Provide alt text to tables. 
A. Right-click a table. 
B. Select Table > Alternative Text. 
C. Type a description and a title. 

 
 Keep consistency of table names in table description, table format, alt text and endings. 
 

7. Use “All Borders” for tables 

 
 
8. No empty cells in tables  
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A. Put in “No data” in data part. 
B. Change the text color to match the background, so only screen reader will read 

it. 
 

9. No merged cells in the DATA part of the table! 
* It is OK to merge cells for descriptions of tables and worksheets. We will merge 
them later. 

 
10. Remove extraneous comments. 

• Comments cannot be read by screen reader. If it’s important, copy it into a cell. 

 
• The red sign on the top right of the cell indicates the comment. Select the cell 

containing the comment, right click and choose Delete Comment. 
 

11. Check all hyperlinks. 
A. Ensure that all hyperlinks work and also show a working URL. 

 
Right-click on the cell and choose Hyperlink if there is not a hyperlink yet, or Edit 
Hyperlink if there is already a hyperlink. 

 
B. Avoid hyperlinks that say, “click here” 

  
• In some cases, it’s better to set the text the same as the address. Your link 

should include everything, including http://     

• Other cases, it’s better to use descriptive words. Here is an example.  
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C. Add a ScreenTip 

• ScreenTips provide additional information about the link and are readable by 
screen readers. 

 
• Right-click on the cell where your URL is located and choose Edit Hyperlink,  

• Choose the ScreenTip button at the top right 

• Type in a meaningful explanation of where the link will take the reader 
 

12. Put all the tables to start in column A. 

• If you have multiple tables in a worksheet, move them to align left, staring in 
column A.  

• Sometimes, multiple tables may have different numbers of columns. We will 
hide totally unused columns later, for those cells in a column that are extra for 
one table, type “kept empty intentionally” in those extra cells and make the 
color match the background.  

 
• If the table contains many cells that need to be typed in “kept empty 

intentionally”, you can merge those extra blank cells and type “kept empty 
intentionally” in that merged cell. Then make the color match the background. 

▪ You can do this after hiding unused columns and rows. We will talk about 
hiding later. 
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13.  End of table 

 
 Type “End of table name table” in the row immediately after the last row of your table. 
 Prefer to merge these cells after hiding rows. 
 

14.  Space between tables 
 Leave only one row between the end of a last table and the description of the 
next table. 

Charts and Images 
1. Provide the description of chart in the cell (column A). 

 
A. Resize the row where you want to insert the chart. You need merge cells to 

match the number of columns used for this worksheet. 
B. Hide the text of description by changing the text color to match the 

background. Only screen readers can read it. 
C. Move the chart into the cell. 

 
2. Ensure that Charts have Alternative Text Descriptions. 

A. Right-click a chart. 
B. Select Format Chart Area > Chart Options > Size & Properties. 
C. Select Alt Text. 
D. Type a description and a title. You can use the previous description here. 

 
 For images, follow the similar process to provide both cell description and alt text. 
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Closing 
1. End of Worksheet: Type “End of Worksheet” in the row immediately after the last 

row of the last table. 
 

 
  

2. Hide extra rows and columns. 
Columns 

A. Select the 1st column you want to hide.  
  

For Windows: Ctrl shift+ -> 
B. While holding down the Shift key, press and release the End key, still holding 

down the shift, now choose the right arrow key. 
C. With your cursor hovering in the selected area, right-click and choose Hide. 

   
 For Mac: Ctrl command+ -> 

       B. While holding down the Shift + Command key, choose the right arrow key. 
C. With your cursor hovering in the selected area, right-click and choose Hide. Or in 
the Format menu, point Column, choose Hide. 

  
Rows 
Hide unused rows below your data, following a similar procedure as to columns.  
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A. Leave 1 blank row below your data, then select the 1st row you want to hide. 
 

For Windows, hold Shift as you press and release End and then press and release 
the down arrow key. 
 
For Mac, hold Shift + Command, choose down arrow key. 
 
B. Right-click and choose Hide. 

 

• If you cannot hide columns or rows in some cases, check whether the region you 
want to hide contains table, chart, or merged sells.  

• If you have merged cells in last row, try unmerging them before hiding unused 
rows.  

• Change the hiding order of columns and rows.  
  

3. If you need put some information later in more columns or rows, unhide these cells 
following the steps below: 

 
A. Select the last visible column.  
B. Hover just to the right side of the right edge of the column header. Your cursor 

should turn from a single cursor with arrows into a double cursor with arrows. 
C. Click and drag to the right, exposing the very last column. 
D. Select the new, final column, and right-click and choose Unhide. 

 
4. Delete unused worksheets 

 
• Right-click on the lab of the unused worksheet and choose Delete 

• *Be careful! This CANNOT be undone. 
 

5. Check spelling 

• Excel does not indicate any spelling errors. In the Review tab, choose Spelling in 
the Proofing group, follow the prompts. 

 
  
 
 
   

• Excel will spell check only one worksheet at a time, not the whole workbook. 
 

6. Check view percentage 
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 Make sure all the worksheets’ view percentage is 100% 

 
 

7. Merge titles and endings 
Based on the remaining columns, merge cells where rows are help text, descriptions of 
worksheet or tables and endings. 

 
8. Final Check: Start Accessibility Checker. 
When you finish your work, look for the Check Accessibility button on the Review tab on 
the Ribbon and click it open the Accessibility Checker. For Mac, click the Tools tab and 
choose the Check Accessibility.  

    
 
If there are any errors, follow the information to modify your file. If there are warnings 
of merged cells, make sure they are not in the data part of the table. 
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